package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)factType=(?<facttype>\w+).+filters=(?<filters>[^\&]+)`)
var str = `msg: abc.asia - [2021-08-23T00:27:08.152+0000] "GET /facts?factType=COMMERCIAL&aaa=2021-08-23T00:27:08.152+00002021-08-23T00:27:08.152+0000&filters=abc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}