// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)factType=(?<facttype>\w+).+filters=(?<filters>[^\&]+)").unwrap();
let string = "msg: abc.asia - [2021-08-23T00:27:08.152+0000] \"GET /facts?factType=COMMERCIAL&aaa=2021-08-23T00:27:08.152+00002021-08-23T00:27:08.152+0000&filters=abc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}