re = /factType=(?<facttype>\w+).+filters=(?<filters>[^\&]+)/m
str = 'msg: abc.asia - [2021-08-23T00:27:08.152+0000] "GET /facts?factType=COMMERCIAL&aaa=2021-08-23T00:27:08.152+00002021-08-23T00:27:08.152+0000&filters=abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end