using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{4})\+(\w+)(?=\w{4}\+|$)";
string substitution = @"";
string input = @"abcd+value1defg+value2hijk+value3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}