$re = '/(\w{4})\+(\w+)(?=\w{4}\+|$)/';
$str = 'abcd+value1defg+value2hijk+value3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;