re = /(\w{4})\+(\w+)(?=\w{4}\+|$)/
str = 'abcd+value1defg+value2hijk+value3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result