import Foundation
let pattern = #"(\w{4})\+(\w+)(?=\w{4}\+|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abcd+value1defg+value2hijk+value3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)