const regex = /(\w{4})\+(\w+)(?=\w{4}\+|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{4})\\+(\\w+)(?=\\w{4}\\+|$)', 'g')
const str = `abcd+value1defg+value2hijk+value3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);