using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:(?:\B[-'&]+|[-'&]+\B|[^-'&[:^punct:]]+)\s*)+";
string substitution = @" ";
string input = @"Good luck!!!!SPRINT I like good deals. I can't lie brand-new stuff---- excites me got& & & & & to say yo, At&t why? a* dash-- apostrophe's''' I can do all-day. But preventing%%%%concatenating is a new**$ballgame but----why--- not?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}