$re = '/\s*(?:(?:\B[-\'&]+|[-\'&]+\B|[^-\'&[:^punct:]]+)\s*)+/';
$str = 'Good luck!!!!SPRINT I like good deals. I can\'t lie brand-new stuff---- excites me got& & & & & to say yo, At&t why? a* dash-- apostrophe\'s\'\'\' I can do all-day. But preventing%%%%concatenating is a new**$ballgame but----why--- not?';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;