const regex = /\s*(?:(?:\B[-'&]+|[-'&]+\B|[^-'&[:^punct:]]+)\s*)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?:(?:\\B[-\'&]+|[-\'&]+\\B|[^-\'&[:^punct:]]+)\\s*)+', 'g')
const str = `Good luck!!!!SPRINT I like good deals. I can't lie brand-new stuff---- excites me got& & & & & to say yo, At&t why? a* dash-- apostrophe's''' I can do all-day. But preventing%%%%concatenating is a new**\$ballgame but----why--- not?`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);