re = /\s*(?:(?:\B[-'&]+|[-'&]+\B|[^-'&[:^punct:]]+)\s*)+/
str = 'Good luck!!!!SPRINT I like good deals. I can\'t lie brand-new stuff---- excites me got& & & & & to say yo, At&t why? a* dash-- apostrophe\'s\'\'\' I can do all-day. But preventing%%%%concatenating is a new**$ballgame but----why--- not?'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result