const regex = /([a-zA-Z]+)\(((?:[\w-]+,?)+)(?::,?([\w-,]+))?\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z]+)\\(((?:[\\w-]+,?)+)(?::,?([\\w-,]+))?\\)', 'g')
const str = `Dependent(7004,700417,2:,1,5,null,3)
Benefit(7004,700417,2,5:,3,35,22)
EmployeeContact(7004,700417,1)
BenefitEnrollmentGroup(7004,HEALTH:700417,1,null,null,null)
BenefitEnrollmentGroup(7004,LIFE-ENROLL:700417,1,null,null,null)
EmployeeBenefit[ByEmployee](7004,700417,CIGNA HDHP,3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}