use strict;
my $str = 'Dependent(7004,700417,2:,1,5,null,3)
Benefit(7004,700417,2,5:,3,35,22)
EmployeeContact(7004,700417,1)
BenefitEnrollmentGroup(7004,HEALTH:700417,1,null,null,null)
BenefitEnrollmentGroup(7004,LIFE-ENROLL:700417,1,null,null,null)
EmployeeBenefit[ByEmployee](7004,700417,CIGNA HDHP,3)';
my $regex = qr/([a-zA-Z]+)\(((?:[\w-]+,?)+)(?::,?([\w-,]+))?\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}