re = /([a-zA-Z]+)\(((?:[\w-]+,?)+)(?::,?([\w-,]+))?\)/
str = 'Dependent(7004,700417,2:,1,5,null,3)
Benefit(7004,700417,2,5:,3,35,22)
EmployeeContact(7004,700417,1)
BenefitEnrollmentGroup(7004,HEALTH:700417,1,null,null,null)
BenefitEnrollmentGroup(7004,LIFE-ENROLL:700417,1,null,null,null)
EmployeeBenefit[ByEmployee](7004,700417,CIGNA HDHP,3)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end