// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z]+)\(((?:[\w-]+,?)+)(?::,?([\w-,]+))?\)").unwrap();
let string = "Dependent(7004,700417,2:,1,5,null,3)
Benefit(7004,700417,2,5:,3,35,22)
EmployeeContact(7004,700417,1)
BenefitEnrollmentGroup(7004,HEALTH:700417,1,null,null,null)
BenefitEnrollmentGroup(7004,LIFE-ENROLL:700417,1,null,null,null)
EmployeeBenefit[ByEmployee](7004,700417,CIGNA HDHP,3)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}