import Foundation
let pattern = #"([a-zA-Z]+)\(((?:[\w-]+,?)+)(?::,?([\w-,]+))?\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Dependent(7004,700417,2:,1,5,null,3)
Benefit(7004,700417,2,5:,3,35,22)
EmployeeContact(7004,700417,1)
BenefitEnrollmentGroup(7004,HEALTH:700417,1,null,null,null)
BenefitEnrollmentGroup(7004,LIFE-ENROLL:700417,1,null,null,null)
EmployeeBenefit[ByEmployee](7004,700417,CIGNA HDHP,3)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)