using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""fluid-width-video-wrapper"".*><iframe(.*?)\(?:src=""(http?:\/\/)|(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{11,12}).*<\/iframe><\/div>";
string input = @"<div class=""fluid-width-video-wrapper"" style=""padding-top: 56.2%;""><iframe src=""https://www.youtube.com/embed/Mpdq4y3wVb8?feature=oembed"" frameborder=""0"" allowfullscreen="" id=""fitvid853335""></iframe></div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}