import re
regex = re.compile(r"""
<div class="fluid-width-video-wrapper".*><iframe(.*?)\(?:src="(http?:\/\/)|(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{11,12}).*<\/iframe><\/div>
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = "<div class=\"fluid-width-video-wrapper\" style=\"padding-top: 56.2%;\"><iframe src=\"https://www.youtube.com/embed/Mpdq4y3wVb8?feature=oembed\" frameborder=\"0\" allowfullscreen=\"\" id=\"fitvid853335\"></iframe></div>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")