$re = '/<div class="fluid-width-video-wrapper".*><iframe(.*?)\(?:src="(http?:\/\/)|(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{11,12}).*<\/iframe><\/div>/ixU';
$str = '<div class="fluid-width-video-wrapper" style="padding-top: 56.2%;"><iframe src="https://www.youtube.com/embed/Mpdq4y3wVb8?feature=oembed" frameborder="0" allowfullscreen="" id="fitvid853335"></iframe></div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);