const regex = /<div class="fluid-width-video-wrapper".*><iframe(.*?)\(?:src="(http?:\/\/)|(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{11,12}).*<\/iframe><\/div>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div class="fluid-width-video-wrapper".*><iframe(.*?)\\(?:src="(http?:\\\/\\\/)|(https?:\\\/\\\/)?(?:www\\.)?(?:youtu\\.be\\\/|youtube\\.com(?:\\\/embed\\\/|\\\/v\\\/|\\\/watch?.*?v=))([\\w\\-]{11,12}).*<\\\/iframe><\\\/div>', 'i')
const str = `<div class="fluid-width-video-wrapper" style="padding-top: 56.2%;"><iframe src="https://www.youtube.com/embed/Mpdq4y3wVb8?feature=oembed" frameborder="0" allowfullscreen="" id="fitvid853335"></iframe></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}