// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ixU)<div class="fluid-width-video-wrapper".*><iframe(.*?)\(?:src="(http?:\/\/)|(https?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com(?:\/embed\/|\/v\/|\/watch?.*?v=))([\w\-]{11,12}).*<\/iframe><\/div>"#).unwrap();
let string = "<div class=\"fluid-width-video-wrapper\" style=\"padding-top: 56.2%;\"><iframe src=\"https://www.youtube.com/embed/Mpdq4y3wVb8?feature=oembed\" frameborder=\"0\" allowfullscreen=\"\" id=\"fitvid853335\"></iframe></div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}