use strict;
my $str = 'CaMeL
cAMEL
caMEL
camEL
cameL
CameL
CAmel
CAMel
CAMeL
cAmEL';
my $regex = qr/\b
(?!\p{Lu}+\b) # CaMeL can't be an ALLCAPS (remove to allow)
(?=\p{L}*\p{Ll}) # CaMeL word should have at least 1 lowercase letter
(?=\p{L}*\p{Lu}) # CaMeL word should have at least 1 uppercase letter
(?!\p{Lu}\p{Ll}*\b) # CaMeL word can't be `Xxxx` or `X`
\p{L}+ # CaMeL word should contain at least 1 letter
\b/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}