$re = '/\b
(?!\p{Lu}+\b) # CaMeL can\'t be an ALLCAPS (remove to allow)
(?=\p{L}*\p{Ll}) # CaMeL word should have at least 1 lowercase letter
(?=\p{L}*\p{Lu}) # CaMeL word should have at least 1 uppercase letter
(?!\p{Lu}\p{Ll}*\b) # CaMeL word can\'t be `Xxxx` or `X`
\p{L}+ # CaMeL word should contain at least 1 letter
\b/x';
$str = 'CaMeL
cAMEL
caMEL
camEL
cameL
CameL
CAmel
CAMel
CAMeL
cAmEL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);