using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9.]+(?=_)";
string input = @"com.abc.def.abcdef-1.6.0_newversion-2.3.7-debug";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}