import re
regex = re.compile(r"[0-9.]+(?=_)")
test_str = "com.abc.def.abcdef-1.6.0_newversion-2.3.7-debug"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")