import Foundation
let pattern = #"[0-9.]+(?=_)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"com.abc.def.abcdef-1.6.0_newversion-2.3.7-debug"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}