const regex = /[0-9.]+(?=_)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9.]+(?=_)', '')
const str = `com.abc.def.abcdef-1.6.0_newversion-2.3.7-debug`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}