const regex = /refs[\\\\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('refs[\\\\\\\\]', '')
const str = `<Reference1>refs\\</Reference1>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);