#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<link href=\"css\/[a-zA-Z\-]+\.css\"[a-zA-Z=\"\/ ]+>"
Local $sString = "<link href="css/normalize.css" >" & @CRLF & _
"<link href="css/normalize.css" rel="stylesheet" type="text/css">" & @CRLF & _
"<link href="css/components.css" rel="stylesheet" type="text/css">" & @CRLF & _
"<link href="css/style-sheet.css" rel="stylesheet" type="text/css">" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")