import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<link href=\\\"css\\/[a-zA-Z\\-]+\\.css\\\"[a-zA-Z=\\\"\\/ ]+>";
final String string = "<link href=\"css/normalize.css\" >\n"
+ "<link href=\"css/normalize.css\" rel=\"stylesheet\" type=\"text/css\">\n"
+ "<link href=\"css/components.css\" rel=\"stylesheet\" type=\"text/css\">\n"
+ "<link href=\"css/style-sheet.css\" rel=\"stylesheet\" type=\"text/css\">\n"
+ " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}