const regex = /<link href=\"css\/[a-zA-Z\-]+\.css\"[a-zA-Z=\"\/ ]+>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<link href=\\"css\\\/[a-zA-Z\\-]+\\.css\\"[a-zA-Z=\\"\\\/ ]+>', 'g')
const str = `<link href="css/normalize.css" >
<link href="css/normalize.css" rel="stylesheet" type="text/css">
<link href="css/components.css" rel="stylesheet" type="text/css">
<link href="css/style-sheet.css" rel="stylesheet" type="text/css">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}