import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\(|nt[A-Z][A-Z][A-Z]|\\)\\s*\\,\\s*|(nt\\d\\d\\d)|,.";
final String string = "Euro (EUR), 1.359, €\n"
+ "US Dollars (USD), 1.34, $\n"
+ "Australian Dollars (AUD), 1.756, $\n"
+ "Canadian Dollars (CAD), 1.71, $\n"
+ "Icelandic króna (ISK), 140.84, kr\n"
+ "United Arab Emirates Dirham (AED), 4.92, د.إ\n"
+ "South African Rand (ZAR), 17.84, R\n"
+ "Thai Baht (THB), 43.58, ฿";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}