use strict;
my $str = 'Euro (EUR), 1.359, €
US Dollars (USD), 1.34, $
Australian Dollars (AUD), 1.756, $
Canadian Dollars (CAD), 1.71, $
Icelandic króna (ISK), 140.84, kr
United Arab Emirates Dirham (AED), 4.92, د.إ
South African Rand (ZAR), 17.84, R
Thai Baht (THB), 43.58, ฿';
my $regex = qr/.*\(|nt[A-Z][A-Z][A-Z]|\)\s*\,\s*|(nt\d\d\d)|,./p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}