// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\(|nt[A-Z][A-Z][A-Z]|\)\s*\,\s*|(nt\d\d\d)|,.").unwrap();
let string = "Euro (EUR), 1.359, €
US Dollars (USD), 1.34, $
Australian Dollars (AUD), 1.756, $
Canadian Dollars (CAD), 1.71, $
Icelandic króna (ISK), 140.84, kr
United Arab Emirates Dirham (AED), 4.92, د.إ
South African Rand (ZAR), 17.84, R
Thai Baht (THB), 43.58, ฿";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}