import Foundation
let pattern = #".*\(|nt[A-Z][A-Z][A-Z]|\)\s*\,\s*|(nt\d\d\d)|,."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Euro (EUR), 1.359, €
US Dollars (USD), 1.34, $
Australian Dollars (AUD), 1.756, $
Canadian Dollars (CAD), 1.71, $
Icelandic króna (ISK), 140.84, kr
United Arab Emirates Dirham (AED), 4.92, د.إ
South African Rand (ZAR), 17.84, R
Thai Baht (THB), 43.58, ฿
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)