const regex = /.*\(|nt[A-Z][A-Z][A-Z]|\)\s*\,\s*|(nt\d\d\d)|,./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\(|nt[A-Z][A-Z][A-Z]|\\)\\s*\\,\\s*|(nt\\d\\d\\d)|,.', 'g')
const str = `Euro (EUR), 1.359, €
US Dollars (USD), 1.34, \$
Australian Dollars (AUD), 1.756, \$
Canadian Dollars (CAD), 1.71, \$
Icelandic króna (ISK), 140.84, kr
United Arab Emirates Dirham (AED), 4.92, د.إ
South African Rand (ZAR), 17.84, R
Thai Baht (THB), 43.58, ฿`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}