#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\.(jpg|gif)$"
Local $sString = "http://reddit.com/r/makemeagif" & @CRLF & _
"http://i.imgur.com/DLX3EUB.gif" & @CRLF & _
"http://animalsadda.com/wp-content/uploads/2013/05/Aye-Aye-4.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")