import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.(jpg|gif)$";
final String string = "http://reddit.com/r/makemeagif\n"
+ "http://i.imgur.com/DLX3EUB.gif\n"
+ "http://animalsadda.com/wp-content/uploads/2013/05/Aye-Aye-4.jpg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}