const regex = /.*\.(jpg|gif)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\.(jpg|gif)$', 'mg')
const str = `http://reddit.com/r/makemeagif
http://i.imgur.com/DLX3EUB.gif
http://animalsadda.com/wp-content/uploads/2013/05/Aye-Aye-4.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}