re = /.*\.(jpg|gif)$/m
str = 'http://reddit.com/r/makemeagif
http://i.imgur.com/DLX3EUB.gif
http://animalsadda.com/wp-content/uploads/2013/05/Aye-Aye-4.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end