$re = '/.*\.(jpg|gif)$/m';
$str = 'http://reddit.com/r/makemeagif
http://i.imgur.com/DLX3EUB.gif
http://animalsadda.com/wp-content/uploads/2013/05/Aye-Aye-4.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);