import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*gov\\.uk$";
final String string = "https://google.com\n"
+ "https://google.gov.uk\n"
+ "www.example.com\n"
+ "www.example.gov.uk\n"
+ "archive.is\n"
+ "something.org\n"
+ "http://wheremyssl.cum\n"
+ "helloworld.gov.uk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}