// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*gov\.uk$").unwrap();
let string = "https://google.com
https://google.gov.uk
www.example.com
www.example.gov.uk
archive.is
something.org
http://wheremyssl.cum
helloworld.gov.uk";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}