$re = '/.*gov\.uk$/m';
$str = 'https://google.com
https://google.gov.uk
www.example.com
www.example.gov.uk
archive.is
something.org
http://wheremyssl.cum
helloworld.gov.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);