const regex = /.*gov\.uk$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*gov\\.uk$', 'gm')
const str = `https://google.com
https://google.gov.uk
www.example.com
www.example.gov.uk
archive.is
something.org
http://wheremyssl.cum
helloworld.gov.uk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}