re = /.*gov\.uk$/m
str = 'https://google.com
https://google.gov.uk
www.example.com
www.example.gov.uk
archive.is
something.org
http://wheremyssl.cum
helloworld.gov.uk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end