using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((([A-Za-z]{3,9}:(?:\/\/)?)(?!(www\.|support\.)*apple\.com|(www\.|forums\.|images\.|cdn\.)*macrumors\.com|(www\.)*youtube\.com|(www\.)*amazon\.|amzn\.to|a\.to)[A-Za-z0-9.-]+[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)";
string input = @"link: [URL] https://www.itunes.com [/URL]
cds http://www.apple.com
cds https://wkmclds.com
https://itunes.com
htt
dcklscmdskl https://cdn.macrumors.com
http://up.co
http://amazo
spam spam";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}