import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([A-Za-z]{3,9}:(?:\\/\\/)?)(?!(www\\.|support\\.)*apple\\.com|(www\\.|forums\\.|images\\.|cdn\\.)*macrumors\\.com|(www\\.)*youtube\\.com|(www\\.)*amazon\\.|amzn\\.to|a\\.to)[A-Za-z0-9.-]+[A-Za-z0-9.-]+)((?:\\/[\\+~%\\/.\\w-_]*)?\\??(?:[-\\+=&;%@.\\w_]*)#?(?:[\\w]*))?)";
final String string = "link: [URL] https://www.itunes.com [/URL]\n\n"
+ "cds http://www.apple.com\n\n"
+ "cds https://wkmclds.com \n\n\n"
+ "https://itunes.com\n"
+ " htt\n"
+ "dcklscmdskl https://cdn.macrumors.com\n"
+ "http://up.co\n"
+ "http://amazo\n\n\n"
+ "spam spam";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}