re = /((([A-Za-z]{3,9}:(?:\/\/)?)(?!(www\.|support\.)*apple\.com|(www\.|forums\.|images\.|cdn\.)*macrumors\.com|(www\.)*youtube\.com|(www\.)*amazon\.|amzn\.to|a\.to)[A-Za-z0-9.-]+[A-Za-z0-9.-]+)((?:\/[\+~%\/.\w-_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[\w]*))?)/m
str = 'link: [URL] https://www.itunes.com [/URL]
cds http://www.apple.com
cds https://wkmclds.com
https://itunes.com
htt
dcklscmdskl https://cdn.macrumors.com
http://up.co
http://amazo
spam spam'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end